fbpx

Filters Widget

HomeTopicsSupport forumFilters Widget
Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #13908
    Avatar
    gary
    Participant

    Hi I quickly tried the same with Woodmart – Installed fresh, checked filters, Imported the 20 products and the Ajax works fine: https://wordpress-554122-1783791.cloudwaysapps.com/index.php/product-category/rahua/

    So has to be an issue with something in Teethys

    Hope this helps get to the bottom of the issue cos dont fancy re-building the site in Woodmart now that I have gotten this far with Teethys

    Thanks

    #13909
    Artem Temos
    Artem Temos
    Keymaster

    Hello,

    Could you please provide us your admin and FTP access so we can check what is wrong?

    Kind Regards

    #13910
    Avatar
    gary
    Participant

    Hi I Sent the login in the last post, – have changed password now

    Have pasted again below for both sites the fresh install and the work in progress

    (Still not getting notifications when you reply to a topic also?)

    #13912
    Artem Temos
    Artem Temos
    Keymaster

    Hello,

    Try to add the following code to the functions.php file in your child theme to fix the bug

    function xts_get_document_title() {
    	$title = wp_get_document_title();
    	$post_meta = get_post_meta( xts_get_page_id(), '_yoast_wpseo_title', true );
    	if ( property_exists( get_queried_object(), 'term_id' ) && function_exists( 'YoastSEO' ) ) {
    		$taxonomy_helper = YoastSEO()->helpers->taxonomy;
    		$meta            = $taxonomy_helper->get_term_meta( get_queried_object() );
    		if ( isset( $meta['wpseo_title'] ) && $meta['wpseo_title'] ) {
    			$title = wpseo_replace_vars( $meta['wpseo_title'], get_queried_object() );
    		}
    	} elseif ( $post_meta && function_exists( 'wpseo_replace_vars' ) ) {
    		$title = wpseo_replace_vars( $post_meta, get_post( xts_get_page_id() ) );
    	}
    	return $title;
    }

    Kind Regards

    #13915
    Avatar
    gary
    Participant

    Hi Thanks for that it seems to have fixed the glitch but now the filters widgets are not working in the filters dropdown on the shop page: https://wordpress-554122-1781676.cloudwaysapps.com/shop/

    They filter once but when you clear filters it does not reset, also if you try and change the filter category it does not work either

    I also tested the Woocommerce Product Filters plugin and that will not work either – It does however work with Woodmart and with Basel so im contemplating switching to Woodmart as they want the checkbox filtering functionality and I dont think im going to be able to achieve this with this theme?

    Can you let me know your thoughts, will you be able to fix the filters?

    Many thanks

    #13916
    Artem Temos
    Artem Temos
    Keymaster

    Try to edit the file js/scripts/layeredNavDropdown.js and add the following code snippet http://prntscr.com/10abpcm

    XTSThemeModule.$document.on('xtsPjaxComplete', function() {
    	XTSThemeModule.layeredNavDropdown();
    });

    Also, disable the following option http://prntscr.com/10abs1z

    #13917
    Avatar
    gary
    Participant

    Hi Thanks for coming back to me, I have added that and changed the setting but didnt seem to do anything? https://wordpress-554122-1781676.cloudwaysapps.com/shop/

    Also my client has asked for Checkbox filters – I installed Woocommerce product filters and it just does not seem to want to work with this theme?

    Do you know if there is an easy fix or should I just us woodmart instead as it seems to work fine with it?

    Many thanks

    #13918
    Artem Temos
    Artem Temos
    Keymaster

    Hello,

    As we can see, filters for brands work well now. The problem is with the categories dropdown now, right?

    As for the plugin, do you mean that it doesn’t work when some of our theme’s AJAX filters are triggered?

    Kind Regards

    #13920
    Avatar
    gary
    Participant

    Hi Problem is with the Filters Dropdown, see screenshot – when a checkbox is checked the results just display 1 product and I dont know why – have installed same plugin in Woodmart and basel and works fine in both

    Is there anything that can be done to get Teethys working like this?

    • This reply was modified 1 month, 2 weeks ago by Avatargary.
    #13922
    Avatar
    gary
    Participant

    Sorry screenshot was to large see screenshot attached

    Attachments:
    You must be logged in to view attached files.
    #13924
    Artem Temos
    Artem Temos
    Keymaster

    Could you please upload an image smaller than 512KB or use some cloud service for screenshots?

    Also, are you able to send us a link to some staging website where it works with WoodMart? It should work the same as Tethys.

    #13925
    Artem Temos
    Artem Temos
    Keymaster

    Strange, but we don’t see this issue on your website now https://gyazo.com/99f5ac311c0d3ecacc7d52de3794002c

    #13926
    Avatar
    gary
    Participant

    Hi Sure Please find login to Woodmart test site that the Filters plugin is working – thats exactly why I chose Teethys as I assumed it was built like Woodmart

    Also just to let you know I dont get mail notifications when you reply to this thread

    Attachments:
    You must be logged in to view attached files.
    #13928
    Artem Temos
    Artem Temos
    Keymaster

    Could you please provide us your FTP access as well?

    #13929
    Avatar
    gary
    Participant

    Ftp Below

    #13930
    Artem Temos
    Artem Temos
    Keymaster

    Try to edit the file themes/tethys/woocommerce/loop/loop-start.php and replace the following code

    <div id="main_loop" class="xts-products<?php echo esc_attr( $wrapper_classes ); ?>" data-source="main_loop" data-paged="1" data-animation-delay="<?php echo esc_attr( $animation_delay ); ?>">

    with this one

    <div id="main_loop" class="xts-products products<?php echo esc_attr( $wrapper_classes ); ?>" data-source="main_loop" data-paged="1" data-animation-delay="<?php echo esc_attr( $animation_delay ); ?>">

    We will also fix it in our next theme update.

    #13931
    Avatar
    gary
    Participant

    Absolute legend one bit of code has made all my problems go away im so so happy!!!!! Thanks so much delighted!

    #13933
    Artem Temos
    Artem Temos
    Keymaster

    Great, I will keep this topic opened. If you notice any issues with filters, contact us so we can check.

    Have a nice day!

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.

Sign in

No account yet?

Create an Account